Author Topic: Please help us find a forum bug!  (Read 17367 times)

Offline Mr. Bill

  • Like a hot cocoa mojito
  • Administrator
  • Forum Veteran
  • *******
  • Posts: 13254
  • Karma: 1805
  • Trained Attack Sheepdog/Troll hunter
    • Website maintenance services by Mr. Bill
Please help us find a forum bug!
« on: May 06, 2011, 06:09:50 PM »
We have a bug.  It shows up in a few different ways:

  • Someone makes a post, but it never shows up in the thread, even though you can see it in their Recent Posts list.
  • Or it shows up, and then vanishes.
  • A thread shows that there is a new post, but when you look there is no new post.

We've seen a few examples, including two today.

If you discover anything like this happening, could you please report it in this thread?  More examples might help us find a pattern and discover the cause.

Thanks very much for your help!

Offline Nicodemus

  • HooHa Man! AKA Docs Whipping Boy
  • Moderator On Leave
  • Survival Veteran
  • *
  • Posts: 8530
  • Karma: 181
  • Wake up and smell the cat food n your bank account
Re: Please help us find a forum bug!
« Reply #1 on: May 06, 2011, 06:36:58 PM »
I saw that in the thread "Odd Food Storage Items" in the "Survivalism & Self Sufficiency Topics > Food Preps > Food Storage" section. judging by the posts that later showed up, it appears that you guys know that there was a problem with it already.

What I can say about that thread is it would display the "new" tag and showed that OKGranny had made a post since I last visited. When I would go to that thread, my post would be the last in the thread with no post afterward. My post ended up being the last on the first page, so I wonder if there might be a problem in going from the first page of posts to the second within a thread.

I should have reported it when I thought it odd, but my computer has been a little buggy of late and so I assumed it was a problem on my end.

If you knew all of this already, and reading this post was a waste of your time, I apologize.  :P

Edit: I just saw that most if not all of this information was posted in the thread "Site Suggestions, Support and Resources > Tech Support and Forum Bugs > Forum Errors". My Bad.
« Last Edit: May 06, 2011, 07:07:59 PM by Nicodemus »


Offline Mr. Bill

  • Like a hot cocoa mojito
  • Administrator
  • Forum Veteran
  • *******
  • Posts: 13254
  • Karma: 1805
  • Trained Attack Sheepdog/Troll hunter
    • Website maintenance services by Mr. Bill
Re: Please help us find a forum bug!
« Reply #2 on: May 06, 2011, 09:25:57 PM »
Thanks, Nicodemus -- it helps to get a thorough description like that.

Offline JerseyVince

  • Dedicated Contributor
  • ******
  • Posts: 1417
  • Karma: 54
Re: Please help us find a forum bug!
« Reply #3 on: May 06, 2011, 09:34:00 PM »
I saw that in the thread "Odd Food Storage Items" in the "Survivalism & Self Sufficiency Topics > Food Preps > Food Storage" section. judging by the posts that later showed up, it appears that you guys know that there was a problem with it already.

What I can say about that thread is it would display the "new" tag and showed that OKGranny had made a post since I last visited. When I would go to that thread, my post would be the last in the thread with no post afterward. My post ended up being the last on the first page, so I wonder if there might be a problem in going from the first page of posts to the second within a thread.

I should have reported it when I thought it odd, but my computer has been a little buggy of late and so I assumed it was a problem on my end.

If you knew all of this already, and reading this post was a waste of your time, I apologize.  :P

Edit: I just saw that most if not all of this information was posted in the thread "Site Suggestions, Support and Resources > Tech Support and Forum Bugs > Forum Errors". My Bad.

i had the exact same problem Nicodemus with the same thread and it was corrected yesterday too

Offline Mr. Bill

  • Like a hot cocoa mojito
  • Administrator
  • Forum Veteran
  • *******
  • Posts: 13254
  • Karma: 1805
  • Trained Attack Sheepdog/Troll hunter
    • Website maintenance services by Mr. Bill
Re: Please help us find a forum bug!
« Reply #4 on: May 06, 2011, 10:40:12 PM »
Archer has been doing some repair work this evening, and I think all the invisible posts have returned from the netherworld. ;D

So what we most need to know now is whether this problem occurs AGAIN (i.e., anytime after right now) on any post.  That will tell us whether we've done a permanent fix, or just a repair of existing damage.

Thanks in advance.

Offline archer

  • Administrator
  • Reporter for the CNN
  • *******
  • Posts: 16761
  • Karma: 370
  • #ImissAmerica
    • Journey to Greener Pastures
Re: Please help us find a forum bug!
« Reply #5 on: May 06, 2011, 10:46:13 PM »
I just ran some maintenance items on the forum and DB and it seems to have fixed some problems,


From a friend: Benjamin Franklin once said that beer is proof that God loves us.
I'm of the opinion that Redheads are proof that, contrary to popular belief, Satan also loves us.
My small blog: http://journeytogreenerpastures.blogspot.com/

Offline dep190

  • Dedicated Contributor
  • ******
  • Posts: 1402
  • Karma: 25
Re: Please help us find a forum bug!
« Reply #6 on: May 07, 2011, 10:46:09 AM »
it seems the old Utube links are all gone.

two days i tryed to log in on the forum link and the whole site was missing

Offline Mr. Bill

  • Like a hot cocoa mojito
  • Administrator
  • Forum Veteran
  • *******
  • Posts: 13254
  • Karma: 1805
  • Trained Attack Sheepdog/Troll hunter
    • Website maintenance services by Mr. Bill
Re: Please help us find a forum bug!
« Reply #7 on: May 07, 2011, 11:38:33 AM »
it seems the old Utube links are all gone.

Youtube links still work (if you click on them), but we lost the ability to embed videos directly into forum posts.  Some of the SMF programmers are having a feud with each other.  I don't think we'll get that feature back.

two days i tryed to log in on the forum link and the whole site was missing

Probably a side-effect of our move to the new server.

Offline TexasGirl

  • Survival Demonstrator
  • *******
  • Posts: 2834
  • Karma: 173
  • Simple country farm girl. Prepper? What's that?
Re: Please help us find a forum bug!
« Reply #8 on: May 07, 2011, 02:03:26 PM »
I didn't realize there were other bugs too, just assumed the bugs yesterday were attracted to Nic's thread because it was full of different kinds of food.  If it pops up again I will gladly donate a can of Raid from my long-term cache.

Thanks for your hard work, guys!  We really appreciate all the behind the scenes operations you guys do to keep us running.

~TG
 

Offline Roknrandy

  • He That Rocks:Viewer Discretion is Advised
  • Global Moderator
  • Survival Demonstrator
  • ******
  • Posts: 2693
  • Karma: 68
  • Master Spammer Obliterator
Re: Please help us find a forum bug!
« Reply #9 on: May 08, 2011, 06:58:51 AM »
I've noticed two different types on "new posts" indicators. One is a gold dot and the other is sheets of paper.


Ya know, the more I think about it the madder I get.  Our motto, what we believed down in our heart, went something like this "ye though I walk through the Valley of Death we will fear no evil...for we are the baddest mother strawberry pickers in the Valley".

FAILURE TO PLAN ON YOUR PART DOES NOT CONSTITUTE AN EMERGENCY ON MY PART

Thox Spuddy

  • Guest
Re: Please help us find a forum bug!
« Reply #10 on: May 08, 2011, 09:41:57 AM »
Don't try to change your avatar, can't be done and you'll lose your previous/present one in the process.

Offline TexasGirl

  • Survival Demonstrator
  • *******
  • Posts: 2834
  • Karma: 173
  • Simple country farm girl. Prepper? What's that?
Re: Please help us find a forum bug!
« Reply #11 on: May 08, 2011, 09:55:03 AM »
I've noticed two different types on "new posts" indicators. One is a gold dot and the other is sheets of paper.

Randy,

Might be something with your theme. I'm running the default and I either get one piece of paper or two depending on whether there is a single new post on that topic or more.

Have you tried changing to a different theme, observing, then changing back?

~TG

 

Offline Roknrandy

  • He That Rocks:Viewer Discretion is Advised
  • Global Moderator
  • Survival Demonstrator
  • ******
  • Posts: 2693
  • Karma: 68
  • Master Spammer Obliterator
Re: Please help us find a forum bug!
« Reply #12 on: May 08, 2011, 11:53:44 AM »
Randy,

Might be something with your theme. I'm running the default and I either get one piece of paper or two depending on whether there is a single new post on that topic or more.

Have you tried changing to a different theme, observing, then changing back?

~TG

TG your right, when I change from Ambassador to SMF default theme it fixes the problem. Great find!
« Last Edit: May 08, 2011, 01:54:15 PM by Roknrandy »

Ya know, the more I think about it the madder I get.  Our motto, what we believed down in our heart, went something like this "ye though I walk through the Valley of Death we will fear no evil...for we are the baddest mother strawberry pickers in the Valley".

FAILURE TO PLAN ON YOUR PART DOES NOT CONSTITUTE AN EMERGENCY ON MY PART

Offline Mr. Bill

  • Like a hot cocoa mojito
  • Administrator
  • Forum Veteran
  • *******
  • Posts: 13254
  • Karma: 1805
  • Trained Attack Sheepdog/Troll hunter
    • Website maintenance services by Mr. Bill
Re: Please help us find a forum bug!
« Reply #13 on: May 08, 2011, 01:11:57 PM »
Don't try to change your avatar, can't be done and you'll lose your previous/present one in the process.

Thanks -- we have a clue what might be causing that problem.  Give us a few days on that.

Offline Sister Wolf

  • The Tiffanator
  • Administrator On Leave
  • Forum Veteran
  • *
  • Posts: 11965
  • Karma: 365
  • Wanna have an adventure?
    • WilderWolf
Re: Please help us find a forum bug!
« Reply #14 on: May 08, 2011, 01:45:37 PM »
Don't try to change your avatar, can't be done and you'll lose your previous/present one in the process.

Wrong?  I just changed mine and it works fine.  I used the "url" version instead of the upload version, but it works, nonetheless.

Also - we've said this before, but it merits being said again.  Your profile pic MUST BE NO GREATER THAN 140 px in any direction.  Otherwise it will not upload.  It's always been that way.  Also, use JPGs, please.  They're smaller than PNGs or TIFs, and WILL work when you're having issues uploading a PNG or a TIF or whatever.


All TSP Members get a 20% discount on any paid membership at Equip 2 Endure! Just enter coupon code "tspforum" (without the quotation marks) to start saving today!

Offline TexDaddy

  • TSP Goat Wrangling Geezer. He is EVIL also.
  • Moderator On Leave
  • Forum Veteran
  • *
  • Posts: 12531
  • Karma: 265
  • I live in Texas. What country are you from?
Re: Please help us find a forum bug!
« Reply #15 on: May 08, 2011, 02:14:35 PM »
...I just changed mine and it works fine...
You certainly were a cute little sparkly glitter princess.
"I went down Virginia, seekin' shelter from the storm.
Caught up in the fable, I watched the tower grow.
Five year plans and new deals, wrapped in golden chains.
And I wonder, still I wonder who'll stop the rain."

...A quote from the book 'Mataroda' comes to mind:
'To do more than your best is impossible, to do less is unthinkable'
WWCD = What would Cedar do?

Offline Sister Wolf

  • The Tiffanator
  • Administrator On Leave
  • Forum Veteran
  • *
  • Posts: 11965
  • Karma: 365
  • Wanna have an adventure?
    • WilderWolf
Re: Please help us find a forum bug!
« Reply #16 on: May 08, 2011, 02:49:35 PM »
You certainly were a cute little sparkly glitter princess.

:)  Thanks.  I was embracing my inner tree hugger.  (I'm fairly sure my grandma was sick of chasing me to get me to put my shoes on and took up the camera instead in this instance)


All TSP Members get a 20% discount on any paid membership at Equip 2 Endure! Just enter coupon code "tspforum" (without the quotation marks) to start saving today!

Thox Spuddy

  • Guest
Re: Please help us find a forum bug!
« Reply #17 on: May 08, 2011, 06:22:48 PM »
Also - we've said this before, but it merits being said again.  Your profile pic MUST BE NO GREATER THAN 140 px in any direction.  Otherwise it will not upload.  It's always been that way.  Also, use JPGs, please.  They're smaller than PNGs or TIFs, and WILL work when you're having issues uploading a PNG or a TIF or whatever.

I tried to upload the same identical jpg that was previously acceptable, but it wouldn't take.

I bring these matters up in light of the topic "Please help us find a forum bug!" request. I am immensely appreciative of and grateful for the efforts of the TSP forum team to navigate this operation. I'm not whining, whatever can't be fixed I can live with, I am only responding to the topic request.

Offline Hurricane

  • Survivalist Mentor
  • *****
  • Posts: 508
  • Karma: 15
Re: Please help us find a forum bug!
« Reply #18 on: May 10, 2011, 06:02:38 PM »
If i may return to the original pagination bug for a moment? I have seen the same type of problem on a completely different forum, using a differernt software package. I don't think it was ever fixed, didn't seem to be a big issue there.  I just waited for someone else to post on the topic, then I could read it all.
Even as men wrecked upon a sand, that look to be
washed off the next tide.

Offline Morning Sunshine

  • Geese Smuggling Moonbat
  • Survival Veteran
  • ********
  • Posts: 5933
  • Karma: 276
  • There are no mistakes, just Learning Experiences
Re: Please help us find a forum bug!
« Reply #19 on: May 10, 2011, 07:04:05 PM »
I am not getting emails for notify topics.  I see them on the new posts page, but no email.
I thought I might just have to re-sign up for new posts on those topics because of the change, but instead of the "notify" button, I have a "unnotify" button, implying that I am supposed to get emails.
"Preparedness, when properly pursued, is a way of life, not a sudden, spectacular program" - Spencer W. Kimball
"Life isn't about trying to survive the storm; but about learning to dance in the rain" - unknown
Luck is what happens when Preparation meets Opportunity

Prepping makes even a hurricane just an inconvenience.

Offline Sister Wolf

  • The Tiffanator
  • Administrator On Leave
  • Forum Veteran
  • *
  • Posts: 11965
  • Karma: 365
  • Wanna have an adventure?
    • WilderWolf
Re: Please help us find a forum bug!
« Reply #20 on: May 10, 2011, 07:42:10 PM »
I am not getting emails for notify topics.  I see them on the new posts page, but no email.
I thought I might just have to re-sign up for new posts on those topics because of the change, but instead of the "notify" button, I have a "unnotify" button, implying that I am supposed to get emails.
Jack is also having this issue.

Either they're ending up in both of your spam folders (unlikely), or one of us will need to mess with the default forum email account.  I'll check that right now.


All TSP Members get a 20% discount on any paid membership at Equip 2 Endure! Just enter coupon code "tspforum" (without the quotation marks) to start saving today!

Offline Sister Wolf

  • The Tiffanator
  • Administrator On Leave
  • Forum Veteran
  • *
  • Posts: 11965
  • Karma: 365
  • Wanna have an adventure?
    • WilderWolf
Re: Please help us find a forum bug!
« Reply #21 on: May 10, 2011, 07:59:07 PM »
Hmph.  I'm not having much luck figuring this one out.

See, it's annoying, because...

I get new topic notifications for this board, and a few others.  I'm receiving those topic notifications.

I also get every single "reported post" email that the forum sends out.  So... why isn't anybody receiving reply notifications??

I'll set this post up for reply notification for me and see if it works.  I can't find ANY help with this on the SMF forum, beyond people who have had issues with Go Daddy (big surprise there).

I'm hoping our email server isn't totally overloaded.  I don't know why it would be... Or even how to go about changing/fixing it if it is.


All TSP Members get a 20% discount on any paid membership at Equip 2 Endure! Just enter coupon code "tspforum" (without the quotation marks) to start saving today!

Offline Mr. Bill

  • Like a hot cocoa mojito
  • Administrator
  • Forum Veteran
  • *******
  • Posts: 13254
  • Karma: 1805
  • Trained Attack Sheepdog/Troll hunter
    • Website maintenance services by Mr. Bill
Re: Please help us find a forum bug!
« Reply #22 on: May 10, 2011, 09:06:22 PM »
I'll set this post up for reply notification for me and see if it works.

Testing reply notification for SW.

How many blues would a blue whale wail if a blue whale could wail blues?

Test complete. 8)

Offline Sister Wolf

  • The Tiffanator
  • Administrator On Leave
  • Forum Veteran
  • *
  • Posts: 11965
  • Karma: 365
  • Wanna have an adventure?
    • WilderWolf
Re: Please help us find a forum bug!
« Reply #23 on: May 10, 2011, 09:18:55 PM »
Works just fine, moby bill.

Subject: Topic reply: Please help us find a forum bug!
On 5/10/2011 8:06 PM, The Survival Podcast Forum - New Server wrote:
> A reply has been posted to a topic you are watching by Mr. Bill.
>
> View the reply at: http://thesurvivalpodcast.com/forum/index.php?topic=27088.new;topicseen#new
>
> Unsubscribe to this topic by using this link: http://thesurvivalpodcast.com/forum/index.php?action=notify;topic=27088.0
>
> More replies may be posted, but you won't receive any more notifications until you read the topic.
>
> Regards,
> The The Survival Podcast Forum - New Server Team.


All TSP Members get a 20% discount on any paid membership at Equip 2 Endure! Just enter coupon code "tspforum" (without the quotation marks) to start saving today!

Thox Spuddy

  • Guest
Re: Please help us find a forum bug!
« Reply #24 on: May 14, 2011, 01:02:44 PM »
Wrong?  I just changed mine and it works fine.  I used the "url" version instead of the upload version, but it works, nonetheless.

Also - we've said this before, but it merits being said again.  Your profile pic MUST BE NO GREATER THAN 140 px in any direction.  Otherwise it will not upload.  It's always been that way.  Also, use JPGs, please.  They're smaller than PNGs or TIFs, and WILL work when you're having issues uploading a PNG or a TIF or whatever.

I just tried the url option, still don't work.

Offline Sister Wolf

  • The Tiffanator
  • Administrator On Leave
  • Forum Veteran
  • *
  • Posts: 11965
  • Karma: 365
  • Wanna have an adventure?
    • WilderWolf
Re: Please help us find a forum bug!
« Reply #25 on: May 14, 2011, 05:01:33 PM »
Here, let me help ya.  Either PM me with the URL or post it here, and I'll get the avatar up for you.  :)


All TSP Members get a 20% discount on any paid membership at Equip 2 Endure! Just enter coupon code "tspforum" (without the quotation marks) to start saving today!