The Survival Podcast Forum

The TSP Marketplace => The Berkey Guy - Berkey Light Water Filters => Topic started by: GodsProvision on January 15, 2019, 08:31:02 PM

Title: new black Berkey filters running fast
Post by: GodsProvision on January 15, 2019, 08:31:02 PM
Brand new black Berkey filters which I primed before installing by using the off grid primer kit. Water runs through very quickly and I am not sure why. Is the plastic separated from the filter? If so, I need to return them.
Title: Re: new black Berkey filters running fast
Post by: Mr. Bill on January 16, 2019, 08:42:09 AM
Just FYI, 'theberkeyguy' hasn't logged on to this forum since Sept 2017, so he's unlikely to see your question here.
Title: Re: new black Berkey filters running fast
Post by: Alan Georges on January 16, 2019, 06:07:04 PM
Give your filter the red food dye test -- a half-dozen drops in the upper container and if the water's coming out significantly less red, you're good to go.  Otherwise, it could be a lot of things.  I'd check that the rubber gaskets are sealing first.  A little (and I mean just a little) film of cooking oil can let things slide and seal down tight.
Title: Re: new black Berkey filters running fast
Post by: Applejack on February 15, 2019, 08:40:47 AM
You can go to the Berkey store website and ask or go to the Berkey Guy website. I did have a set of filters that the ends came loose. I called them and they replaced them for free. It sounds like you might be having the same problem. They did have a series of filters that had a problem and they have been replacing them for people.