Author Topic: Yes, I broke the forum today  (Read 1114 times)

Offline Mr. Bill

  • Like a hot cocoa mojito
  • Administrator
  • Ultimate Survival Veteran
  • *******
  • Posts: 15042
  • Karma: 1872
  • Trained Attack Sheepdog/Troll hunter
    • Website Maintenance and Online Presence Management by Mr. Bill
Yes, I broke the forum today
« on: October 14, 2019, 04:48:51 PM »
Sorry about that.  Forum was probably malfunctioning for 2 or 3 hours.

The cause: I added a cache plugin to Jack's blog. :pissed:

WHY does a Wordpress cache affect a not-Wordpress forum?  Probably because the forum is in a subdirectory under the blog's URL.  Anyway, we're functional again (I think), and I'll do some research before I re-enable that stupid cache.

Offline iam4liberty

  • Survival Demonstrator
  • *******
  • Posts: 4471
  • Karma: 333
  • New TSP Forum member
Re: Yes, I broke the forum today
« Reply #1 on: October 14, 2019, 04:55:13 PM »
Dont beat yourself up over it.  You are doing a fine job.  Word Press plugins are becoming an issue everywhere.

Offline Mr. Bill

  • Like a hot cocoa mojito
  • Administrator
  • Ultimate Survival Veteran
  • *******
  • Posts: 15042
  • Karma: 1872
  • Trained Attack Sheepdog/Troll hunter
    • Website Maintenance and Online Presence Management by Mr. Bill
Re: Yes, I broke the forum today
« Reply #2 on: October 14, 2019, 05:02:41 PM »
Thanks.  There's a workaround, I'm sure -- I just don't know what it is yet.

When the forum was set up 11 years ago, it probably ought to have gone in its own domain or subdomain.  It would be hard to undo that decision today.  So I'm hoping there's something in the cache plugin settings, or maybe something we can do in .htaccess, that will eliminate this conflict.  Anyway, that's research for another day.  Time to go make a meatloaf.

Offline surfivor

  • Survival Veteran
  • ********
  • Posts: 7350
  • Karma: 110
Re: Yes, I broke the forum today
« Reply #3 on: October 15, 2019, 12:08:21 AM »
My first web development job was doing WordPress, integration of plugins and php. I prefer Ruby on Rails or JavaScript frameworks like react.js. I didn’t enjoy the php days so much

Offline Mr. Bill

  • Like a hot cocoa mojito
  • Administrator
  • Ultimate Survival Veteran
  • *******
  • Posts: 15042
  • Karma: 1872
  • Trained Attack Sheepdog/Troll hunter
    • Website Maintenance and Online Presence Management by Mr. Bill
Re: Yes, I broke the forum today
« Reply #4 on: October 15, 2019, 09:14:23 AM »
It would be an interesting project to replace Jack's galaxy of websites with a unified custom-designed system.  And by "interesting project" I mean "team of six programmers working for six months and squashing bugs for another six months, while Mr. Bill has fled to Antarctica".

I probably found the workaround for the cache bug (there's an "exclude" list that is going to need about 4 dozen items listed).

Offline Mr. Bill

  • Like a hot cocoa mojito
  • Administrator
  • Ultimate Survival Veteran
  • *******
  • Posts: 15042
  • Karma: 1872
  • Trained Attack Sheepdog/Troll hunter
    • Website Maintenance and Online Presence Management by Mr. Bill
Re: Yes, I broke the forum today
« Reply #5 on: October 22, 2019, 06:41:53 PM »
I set up the fix for the problem, and it didn't fix the problem and broke the forum again.  Currently communicating with the cache plugin's author.

I may be doing some experiments over the next few days, and the forum will probably break for 2 or 3 minutes at a time while I'm doing that.  Apologies in advance.  If something doesn't work, try again in a few minutes.

Offline Stwood

  • Survival Demonstrator
  • *******
  • Posts: 4699
  • Karma: 70
  • Wut wuz dat Olie?
Re: Yes, I broke the forum today
« Reply #6 on: October 23, 2019, 08:05:33 AM »
 :popcorn:

Offline Mr. Bill

  • Like a hot cocoa mojito
  • Administrator
  • Ultimate Survival Veteran
  • *******
  • Posts: 15042
  • Karma: 1872
  • Trained Attack Sheepdog/Troll hunter
    • Website Maintenance and Online Presence Management by Mr. Bill
Re: Yes, I broke the forum today
« Reply #7 on: March 19, 2020, 07:53:39 AM »
Sorry about that.  Forum was probably malfunctioning for 2 or 3 hours.

The cause: I added a cache plugin to Jack's blog. :pissed:

The faulty cache plugin has been disabled since October.

Then yesterday evening, Archer discovered it and said "I wonder what happens if we turn this on?"

 :facepalm:

Anyway, that's why the forum was broken for a few hours late yesterday.

(But also, Archer rescued the site from massive slowdowns a few days ago.  We were under attack AGAIN from mysterious unknown parties, and he blocked the evildoers.  So, hats off for that fix!)

Offline Bradbn4

  • Dedicated Contributor
  • ******
  • Posts: 1352
  • Karma: 38
Re: Yes, I broke the forum today
« Reply #8 on: March 19, 2020, 08:02:51 AM »
Good work finding the problem and fixing it....

Just like the saying "Earl, hold my beer"; "I wonder what does this do or why it is not running" can lead to interesting times.

Offline Stwood

  • Survival Demonstrator
  • *******
  • Posts: 4699
  • Karma: 70
  • Wut wuz dat Olie?
Re: Yes, I broke the forum today
« Reply #9 on: March 19, 2020, 08:44:18 AM »
Never noticed. Must have happened yesterday while I was off.

Offline Carver

  • Survivalist Mentor
  • *****
  • Posts: 388
  • Karma: 19
  • New TSP Forum member
Re: Yes, I broke the forum today
« Reply #10 on: March 19, 2020, 09:19:50 AM »

:-*